关于解决国际服设备不兼容问题的一些经验

经常看到一些小伙伴们因为设备不兼容而苦恼,商店搜不到!氪金氪不了!如何是好?

下面我来分享一下我关于解决这个问题的一些经验(须知:以下是我的一些经验,可以尝试,但不保证正在看此帖的你适用)

好啦,正式开始之前,请明确一件事:都2020年了,几乎没有那个手机说是真正不兼容光遇,我确信这些都是可以解决的(Android8以下的请忽略:D:D

以下请逐条尝试

#1 未root
在谷歌商店搜不到光遇,在浏览器搜到光遇跳转到谷歌商店却显示这样,特别是之前兼容,突然就不兼容了,没错不要慌,老bug了,下面听我操作

解决办法:清除谷歌三件套数据(如下图这三位,打开设置-应用-搜索google),然后重新搜索(此操作并不会影响您的游戏存档)已经有很多朋友成功了,不来试试嘛?
#2 root过且并未安装xposed框架
一部分root过的手机会显示 设备未通过认证(打开商店-设置-拉到最下)

原因是未通过SafetyNet验证(下图是已通过)

解决办法:默认你是用magisk进行的root且会使用magisk
先下载Busybox for Android NDKMagiskHide Props ConfigRiru(Riru-Core)这三个模块,(最好在magisk自己的库中找),若启用之后还不行就请参考这个如何通过SaftyNet 其中的终端模拟器可以任意使用,我用的是Termux(P.S.我就是这么搞定哒)
也有人说自己未通过也可以搜到并正常下载,但至少我的情况是未通过就搜不到,通过就搜得到,不妨一试,有效请点赞,无效请忽视

#3 root过并安装xposed
目前我知道的解决办法就是卸载xposed(逃~
kindyear

kindyear

因为爱,所以挚爱

相关推荐

1 条评论

  1. Remember

    补充一下,我手机自己更新的最新版的google play服务一直显示设备不兼容,清除了所有数据也没用,我把它卸载了,使用预装的旧版本就可以用了。如果后期又出现不兼容问题,查看一下是否挂对了对应地区的魔法,还有就是play有没有自动更新。

发表评论

邮箱地址不会被公开。 必填项已用*标注

返回顶部

显示

忘记密码?

显示

显示

获取验证码

Close